Mi Piace! Mi Piace!:  8
NON mi piace! NON mi piace!:  0
Grazie! Grazie!:  1
Pagina 2 di 2 primaprima 12
Visualizzazione dei risultati da 21 a 33 su 33

Discussione: ORION BMS - Configurazione hardware/software - Chi ha esperienze in merito?

  1. #21
    Appassionato/a

    User Info Menu

    Predefinito



    Quote Originariamente inviata da BonannoM Visualizza il messaggio
    Ciao Fernando,

    Solo un'ultima curiosita..
    sul tuo ultimo screenshot noto un Soc del 79% ed un notevole sbilancio fra la cella piu alta e la più bassa.. oltre che un una resistenza interna delle celle molto alta... come mai?
    Il Soc lo trovo abbastanza corretto, quando ho fatto la foto avevo percorso circa 40 km. Invece grazie a questo sistema mi sono accorto che ho un grosso problema di resistenza interna che si traduce in squilibrio delle tensioni sotto carico, le quali tornano allineate a vuoto. Ho già smontato una volta il pacco batterie per migliorare alcune connessioni che mi sembravano critiche, ma ho paura a stringere troppo per paura di sfilettare il prigioniero in alluminio presente sulla cella. In questo momento non ho voglia di smontare nuovamente il pacco batterie, però sto prendendo nota delle segnalazioni di "weak" da parte di Orion in modo che alla prossima occasione possa intervenire puntualmente. Ho anche ordinato un misuratore di resistenza interna a 4 fili (ne ho trovato uno economico a 40 euro), sperando che mi aiuti ad ottimizzare le connessioni. Al momento ho dovuto abbassare la soglia minima di tensione a 2,5 per evitare che il cicalino intervenga continuamente. Ho scaricato le foto che hai postato delle resistenze interne del tuo pacco batterie, giusto per avere un riferimento di punto di arrivo.
    Ho già pensato di installare un Arduino, anche alla luce del fatto che la BM non funziona, ma sto rimandando, perchè conoscendomi comincerei ad implementare un sacco di funzioni (sai com'è un'automazione tira l'altra, mi è già successo quando ho automatizzato il condizionamento di casa) perdendoci un sacco di tempo che al momento non ho. Per ora quindi ci sto solo ragionando su.

  2. #22
    Appassionato/a

    User Info Menu

    Predefinito

    Se può tornarti utile le resistenze delle mie celle variano con il variare delle temperature (in inverno aumentano ed in estate diminuiscono) ma la cosa strana e che variano di poco continuamente durante la marcia... ma ormai non le guardo più e mi limito ad osservare solo le singole tensioni.
    Ma dimmi, come sei riuscito ad ottenere il valore dei W/km?
    Ogni cosa è passione...!!

  3. #23
    Appassionato/a

    User Info Menu

    Predefinito

    Quote Originariamente inviata da BonannoM Visualizza il messaggio
    Ma dimmi, come sei riuscito ad ottenere il valore dei W/km?
    Ottima domanda, ti ringrazio per avermela fatta
    In realtà ho tribolato parecchio, ho dovuto prima creare un PID con la Potenza Istantanea, poiché quello di serie non ne voleva sapere di funzionare alla fine ne ho fatto semplicemente Vbatt X Ibatt, entrambe disponibili e funzionanti. Per le funzioni ho dovuto usare i codici esadecimali per richiamare gli altri PID in quanto con i nomi non sono riuscito a farli funzionare.
    Ottenuta la Potenza Istantanea ho creato un altro PID che va il rapporto tra la potenza istantanea e la velocità GPS. Questo valore oscilla parecchio durante la marcia e quando sei fermo va all'infinito, per cui conviene impostare un massimo ed un minimo. Io ho messo anche un grafico, in modo da avere anche un'idea dell'andamento. Sarebbe bello riuscire a fare qualcosa di più stabile, che agisca su valori medi, ma sinceramente non saprei come ottenerli, non so come memorizzare i dati. Se si riuscisse a fare si potrebbe ottenere anche una stima dell'autonomia residua in base allo stile di guida recente.
    Per quanto riguarda le resistenze interne, tieni presente che i valori letti dall'Orion comprendono anche la resistenza di collegamento tra il polo negativo della cella letta e quello positivo della cella precedente, trattandosi poi di mOhm tutto fa brodo. Il fatto che variano durante la marcia è normale perché cambiano le condizioni di carico, ed a elevate correnti si fanno sentire fenomeni che normalmente non si manifestano (sempre perché parliamo di mOhm). Difatti l'Orion calcola continuamente la resistenza durante la marcia, finché sei fermo utilizza dati di default.
    La mia preoccupazione è proprio rivolta alle connessioni, poiché 10 mOhm a 100 A sviluppano 100 W che si traduce in calore.

  4. #24
    TUTOR

    User Info Menu

    Predefinito

    bellissimo lavoro, display spettacolare!

    Proprio per questo e chiedendo scusa in anticipo... ma visto che siamo su livelli elevati il consumo è in Wh/km e non W/km, mi raccomando!
    Certificatore energetico (ex?) in Lombardia

    FIAT Seicento Elettra 'Eli': http://www.energeticambiente.it/fiat...ia-di-eli.html

    Ecolà-Retrofit elettrico di una Lambretta del 1952: http://www.energeticambiente.it/categoria-l1-l3-es-scooters-moto-trasformate-elettriche/14725064-e-arrivo-la-ecola.html

    riqualificazione energetica del mio appartamento:http://www.energeticambiente.it/sist...-ho-fatto.html

  5. #25
    Appassionato/a

    User Info Menu

    Predefinito

    Quote Originariamente inviata da riccardo urciuoli Visualizza il messaggio
    i il consumo è in Wh/km e non W/km, mi raccomando!
    Giustissima osservazione Riccardo, non me ne ero proprio accorto

  6. #26
    Appassionato/a

    User Info Menu

    Predefinito ORION BMS - Configurazione hardware/software - Chi ha esperienze in merito?

    Bravo Fernando! Ottimo lavoro..

    Ti andrebbe di postare qualche screenshot dei PID che hai creato?
    Io penso di averle provate tutte ma non sono mai riuscito ad ottenere la potenza istantanea (VxI).
    Anche le altre funzioni credo siano interessanti per il thread e potrebbero tornare utili come base di partenza per gli altri utenti..
    Ogni cosa è passione...!!

  7. #27
    Appassionato/a

    User Info Menu

    Predefinito

    Consumo 1.jpgConsumo 2.jpgConsumo 3.jpgConsumo 4.jpgConsumo 5.jpg
    Questo è il PID del Consumo che però richiama il successivo della Potenza che quindi va creato prima

  8. #28
    Appassionato/a

    User Info Menu

    Predefinito

    Potenza 1.jpgPotenza 2.jpgPotenza 3.jpgPotenza 4.jpgPotenza 4.jpgPotenza 5.jpg
    Questo è quello della Potenza che appunto va creato prima. C'è già un PID della Potenza nella lista per Orion, ma a me non ne vuole sapere di funzionare quindi ne ho creato uno io.
    Faccio notare che nelle formule ho dovuto usare gli indirizzi esadecimali per richiamare i PID. All'inizio ho provato usando i nomi ma non funzionavano. Anche ai PID che ho creato ho dovuto assegnare un codice esadecimale, che ho inventato io cercando di non interferire con quelli esistenti.

  9. #29
    Appassionato/a

    User Info Menu

    Predefinito

    Generale.jpg
    Questo è come sono visualizzati nell'elenco dei PIDs.
    Per ora ho postato le foto ma spero di riuscire ad aggiornare presto l'elenco in excel dei PID di Orion, anche per ordine mio.

  10. #30
    Appassionato/a

    User Info Menu

    Predefinito

    orionbms_pids fernando.xlsx
    Questo è il file excel con tutti i PID per Orion che ho trovato a cui ho aggiunto i due creati da me. Ho dimenticato di precisare che nella formula del Consumo medio, alla velocità ho aggiunto un valore fisso di 0,1 km/h. Questo anche se aggiunge una piccola imprecisione nel calcolo mi evita che da fermo il consumo vada all'infinito.

  11. #31
    Appassionato/a

    User Info Menu

    Predefinito ORION BMS - Configurazione hardware/software - Chi ha esperienze in merito?

    Complimenti Fernando,
    appena possibile li testerò sul mio Torque.. [emoji6]
    Ogni cosa è passione...!!

  12. #32
    Appassionato/a

    User Info Menu

    Predefinito

    Fernando
    finalmente ho avuto modo testare i tuoi PID sul mio ORION ma sfortunatamente a me non funzionano..
    non so se ci sono differenze sostanziali tra i nostri bms ma le tue formule di calcolo della potenza e del consumo medio sul mio non restituiscono risultati

    PID (3).JPG

    Come puoi vedere la sintassi della formula è esattamente come riportato sulle foto da te pubblicate...

    PID (6).jpg

    Torque non segnala errori.. ma sembra come se qualcosa non funzioni con il "nome" del PID contenuto nel primo rigo di configurazione.
    Ho fatto varie prove ed alla fine sono riuscito a farla funzionare cancellando appunto il nome del PID (22F110) e lasciando al suo posto il campo vuoto..

    Adesso ho il valore della potenza espressa in KW.

    Analogo problema l'ho avuto con il PID relativo al consumo medio...

    PID (5).jpg

    tolto il "nome" dal primo rigo, l'errore "NO DATA" non è più comparso ma il display restituiva un valore di "0,0"

    in effetti pensandoci, dopo aver applicato la modifica di sopra togliendo il nome, risulta impossibile richiamare il valore della potenza... e così dopo alcune prove ho pensato di richiamarlo utilizzando una sintassi diversa.

    PID (4).jpg

    La formula così modificata ha funzionato ed in questo modo sono riuscito a ricevere dei dati ma non credo siano quelli relativi al consumo medio.. probabilmente mi manca l'incrocio con qualche altro valore, a tal proposito ti chiedo, quale valore dovreebbe richiamare FF1001?
    Ogni cosa è passione...!!

  13. #33
    Appassionato/a

    User Info Menu

    Predefinito

    Ciao Marcello,
    il codice 22F110 l'ho inventato io ed ho dovuto usarlo perchè a me, invece, non funzionano le formule usando i nomi dei PID, ma visto che a te sembrano funzionare puoi procedere come hai fatto. Quando inventi un codice devi anche stare attento a non sovrapporti a quelli già esistenti, potrebbero nascere conflitti.
    Ho dato per scontato che, come me, tu abbia caricato l'elenco dei PID con le istruzioni riportate nel seguente link:
    Setting Up Torque | Orion Li-Ion Battery Management System
    Per quanto riguarda il PID con codice FF1001 sul mio sistema rappresenta la Velocità GPS, verifica che corrisponda anche nel tuo.
    Eventualmente fai prima una prova con uno strumento che indichi solo quello.
    Forse tu puoi evitare i codici esadecimali ed usare direttamente i nomi delle variabili come hai fatto per la potenza.

  14. RAD
Pagina 2 di 2 primaprima 12

Discussioni simili

  1. Errore hardware inverter Kloben
    Da marcolo88 nel forum Pompe di Calore e Condizionatori
    Risposte: 4
    Ultimo messaggio: 20-11-2017, 11:10
  2. SDS MICRO hardware interessante per monitorare
    Da spider61 nel forum Tecnica, componentistica e installazione
    Risposte: 0
    Ultimo messaggio: 09-07-2014, 09:30
  3. Chiarimenti in merito alla domanda di connessione
    Da alchimista.vv nel forum Tecnica, componentistica e installazione
    Risposte: 6
    Ultimo messaggio: 19-01-2011, 16:36
  4. Cosa dice il GSE in merito allo scambio >20 kWp
    Da Ing. Artico Mario nel forum Legislazione, normative e comunicati ufficiali
    Risposte: 4
    Ultimo messaggio: 01-06-2010, 20:26
  5. Operazione Orion - Articolo
    Da Fausto Intilla nel forum Collegamenti/Links, Libri/Books, Riviste/Magazines, ecc./etc.
    Risposte: 0
    Ultimo messaggio: 25-02-2007, 15:09

Tag per questa discussione

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •