annuncio

Comprimi
Ancora nessun annuncio.

Monitoraggio Inverter ABB UNO di qualche anno fa

Comprimi
X
 
  • Filtro
  • Ora
  • Visualizza
Elimina tutto
nuovi messaggi

  • Monitoraggio Inverter ABB UNO di qualche anno fa

    Ciao a tutti,

    sono nuovo, anzi nuovissimo. Sono approdato su questo forum quando cercavo di iniziare il monitoraggio dell'inverter ABB UNO che mi è stato montato alcuni anni fa (credo sia un 2016) in seguito al guasto del precedente.

    L'impianto è monofase da 5,8kwp su due stringhe.

    Una premessa: controllavo il precedente inverter con un mio script su un raspberry pi via RS485 con adattatore USB PL2303.

    In seguito alla sostituzione dell'inverter ho spostato il cavo RS485, ma accortomi che in pochi minuti non riuscivo a leggere i dati ho accantonato l'idea fino a ieri.

    Purtroppo, il tempo passato mi rende difficile reperire informazioni in rete. Anche sul sito ABB non trovo più dati sul mio inverter e il modello attuale sembra diverso.

    Dalla ricerca in rete e da alcune immagini ho inizialmente avuto la sensazione che il mio inverter dovesse parlare il protocollo Aurora e ho provato l'apposito eseguibile per raspberry nel tentativo di comunicare senza successo.

    Altre discussioni mi hanno invece fatto pensare che il mio invertire parli solo MODBUS RTU (forse fisso a 19200baud), ma anche in questo caso non sono riuscito a comunicarci.

    Veniamo alle domande che ho maturato:


    Nei miei tentativi ho osservato che sulla seriale in oggetto vedo un flusso continuo di caratteri che non vengono interpretati e soprattutto non sono richiesti.
    L’adattatore USB PL2303 in mio possesso ha solo i fili A e B, cosa faccio col GND? Ho visto alcuni post in rete in cui sembra che molti semplicemente non lo colleghino. Potrebbe essere questo il mio problema?

    Ho notato in rete (ad esempio su amazon) quelli che mi sembrano adattatori MODBUS TCP -> RS485, mi servirebbe un prodotto di questo tipo? Sono prodotti standard o dovrei cercare quello ABB?

    Sull’inverter ho ovviamente impostato la terminazione 120Ohm a on, ma in alcuni post in rete in cui parlano del dialogo tra raspberry pi e inverter citano l’esigenza di una resistenza da 120Ohm, che poi non dicono dove andrebbe applicata. Serve da qualche parte?

    C’è qualcuno sul forum che tiene sotto controllo questo tipo di inverter mi può aiutare almeno ad identificare i manuali o comunque come posso fare?

    Grazie.

    Marco

  • #2
    Visto che non mi ha risposto nessuno, a futura memoria scrivo la soluzione se qualcuno incorresse nello stesso problema.

    Ho sostituito l'adattatore USB con un CH340 che ha - giustamente - anche il terzo filo e tutto ha cominciato a funzionare con aurora.

    Marco

    Commenta

    Attendi un attimo...
    X
    TOP100-SOLAR